http://loverain.blog.51cto.com/2271638/814332 R1、R2、R3模拟企业内网跑EIGRP路由协议,R3是企业网关,实现全网互通,内网通过NAT转换访问Internet,测试目标为4.4.4.4/24 R1 en conf t line con 0 no exec-t exit host R1 int f0/0 no sh ip add 192.168.12.1 255...
http://loverain.blog.51cto.com/2271638/814332
R1、R2、R3模拟企业内网跑EIGRP路路由协议,R3是企业网关,实现全网互通,内网通过NAT转换访问Internet,测试目标为4.4.4.4/24
R1
en
conf t
line con 0
no exec-t
exit
host R1
int f0/0
no sh
ip add 192.168.12.1 255.255.255.0
exit
router eigrp 100
no au
net 192.168.12.0 0.0.0.255
end
R1
en
conf t
line con 0
no exec-t
exit
host R1
int f0/0
no sh
ip add 192.168.12.1 255.255.255.0
exit
router eigrp 100
no au
net 192.168.12.0 0.0.0.255
end
===================R2===========================
en
conf t
line con 0
no exec-t
exit
host R2
int f0/0
no sh
ip add 192.168.12.2 255.255.255.0
int f1/0
no sh
ip add 192.168.23.2 255.255.255.0
exit
router eigrp 100
no au
net 192.168.12.0 0.0.0.255
net 192.168.23.0 0.0.0.255
end
en
conf t
line con 0
no exec-t
exit
host R2
int f0/0
no sh
ip add 192.168.12.2 255.255.255.0
int f1/0
no sh
ip add 192.168.23.2 255.255.255.0
exit
router eigrp 100
no au
net 192.168.12.0 0.0.0.255
net 192.168.23.0 0.0.0.255
end
================R3================================
en
conf t
line con 0
no exec-t
exit
host R3
int f0/0
no sh
ip add 192.168.23.3 255.255.255.0
int f1/0
no sh
ip add 34.34.34.3 255.255.255.0
int lo 0
ip add 3.3.3.3 255.0.0.0
exit
router eigrp 100
no au
net 192.168.23.0 0.0.0.255
net 3.3.3.3 0.0.0.0
end
en
conf t
line con 0
no exec-t
exit
host R3
int f0/0
no sh
ip add 192.168.23.3 255.255.255.0
int f1/0
no sh
ip add 34.34.34.3 255.255.255.0
int lo 0
ip add 3.3.3.3 255.0.0.0
exit
router eigrp 100
no au
net 192.168.23.0 0.0.0.255
net 3.3.3.3 0.0.0.0
end
R3(config)#ip default-network 3.0.0.0
R3(config)#ip route 0.0.0.0 0.0.0.0 34.34.34.4
R3(config)#ip route 0.0.0.0 0.0.0.0 34.34.34.4
NAT配置
R3(config)#access-list 1 permit 192.168.0.0 0.0.255.255
R3(config)#ip nat inside source list 1 interface FastEthernet1/0 overload
R3(config)#interface FastEthernet0/0
R3(config-if)#ip nat inside
R3(config)#interface FastEthernet1/0
R3(config-if)#ip nat outside
R3(config)#access-list 1 permit 192.168.0.0 0.0.255.255
R3(config)#ip nat inside source list 1 interface FastEthernet1/0 overload
R3(config)#interface FastEthernet0/0
R3(config-if)#ip nat inside
R3(config)#interface FastEthernet1/0
R3(config-if)#ip nat outside
===================R4===========================
en
conf t
line con 0
no exec-t
exit
host R4
int f0/0
no sh
ip add 34.34.34.4 255.255.255.0
int lo0
no sh
ip add 4.4.4.4 255.255.255.0
en
conf t
line con 0
no exec-t
exit
host R4
int f0/0
no sh
ip add 34.34.34.4 255.255.255.0
int lo0
no sh
ip add 4.4.4.4 255.255.255.0
实验调试
R1#sh ip route
Gateway of last resort is 192.168.12.2 to network 3.0.0.0
Gateway of last resort is 192.168.12.2 to network 3.0.0.0
C 192.168.12.0/24 is directly connected, FastEthernet0/0
D* 3.0.0.0/8 [90/158720] via 192.168.12.2, 00:00:12, FastEthernet0/0
D 192.168.23.0/24 [90/30720] via 192.168.12.2, 00:07:52, FastEthernet0/0
D* 3.0.0.0/8 [90/158720] via 192.168.12.2, 00:00:12, FastEthernet0/0
D 192.168.23.0/24 [90/30720] via 192.168.12.2, 00:07:52, FastEthernet0/0
R2#sh ip route
Gateway of last resort is 192.168.23.3 to network 3.0.0.0
Gateway of last resort is 192.168.23.3 to network 3.0.0.0
C 192.168.12.0/24 is directly connected, FastEthernet0/0
D* 3.0.0.0/8 [90/156160] via 192.168.23.3, 00:01:13, FastEthernet1/0
C 192.168.23.0/24 is directly connected, FastEthernet1/0
D* 3.0.0.0/8 [90/156160] via 192.168.23.3, 00:01:13, FastEthernet1/0
C 192.168.23.0/24 is directly connected, FastEthernet1/0
实验比较
在上篇文章中,RIPv 2在企业中应用,向内网注入默认路路由时,R3的外接口进程未宣告进RIP协议中,而EIGRP中,必须将接口宣告进EIGRP进程中。否则无法产生EIGRP的默认路路由
请看下例:
R1#sh ip route
C 192.168.12.0/24 is directly connected, FastEthernet0/0
D 192.168.23.0/24 [90/30720] via 192.168.12.2, 00:04:29, FastEthernet0/0
R1#ping 4.4.4.4
C 192.168.12.0/24 is directly connected, FastEthernet0/0
D 192.168.23.0/24 [90/30720] via 192.168.12.2, 00:04:29, FastEthernet0/0
R1#ping 4.4.4.4
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 4.4.4.4,
Sending 5, 100-byte ICMP Echos to 4.4.4.4,
timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
.....
Success rate is 0 percent (0/5)
当将lo 0宣告进EIGRP进程后
R1#sh ip route
Gateway of last resort is 192.168.12.2 to network 3.0.0.0
Gateway of last resort is 192.168.12.2 to network 3.0.0.0
C 192.168.12.0/24 is directly connected, FastEthernet0/0
D* 3.0.0.0/8 [90/158720] via 192.168.12.2, 00:00:12, FastEthernet0/0
D 192.168.23.0/24 [90/30720] via 192.168.12.2, 00:07:52, FastEthernet0/0
R1#ping 4.4.4.4
D* 3.0.0.0/8 [90/158720] via 192.168.12.2, 00:00:12, FastEthernet0/0
D 192.168.23.0/24 [90/30720] via 192.168.12.2, 00:07:52, FastEthernet0/0
R1#ping 4.4.4.4
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:
!!!!!
Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:
!!!!!
上一篇:网络流量限速方法 下一篇:Multiple Web Servers
tags:EIGRP,业内,应用,http,loverain.blog